Results 1 to 5 of 5

Thread: Issues with delay

  1. #1

    Default Issues with delay

    Maybe (ok AM) doing this wrong to have a panel jump after a delay.

    I have a button that runs a progress bar countdown and that works.

    I want the button to delay a panel jump while the progress bar is counting down
    and then jump to a new panel 1 second after the progress bar stops.

    But when I put those three together in the button action designer, the entire
    thing freezes (the graphic for the button down press just sticks) then after the
    delay the panel jumps.

    How do I make it so the delay does not shut everything down?

  2. #2

    Default

    Ok so in reading Ive discovered that netremote does not draw its display when excuting a lua script.

    So I tried the wait for variable.

    I set the {projtimer_progress} frame to display the countdown from my progress bar thinking that wait for variable would see it hit 1 then do the next command in the action list which is a panel jump....seems logical but what do I know, it does not work.

  3. #3
    Join Date
    Mar 2005
    Location
    Los Angeles, CA
    Posts
    1,003

    Default

    One approach to animate a progress bar would be to drive it from Girder: have Girder change the value of a NetRemote variable, and use that variable on the NetRemote side as the index for what image to be displayed.

    Cheers,
    Tim

  4. #4

    Default

    I have the progress bar working fine as well as the countdown timer if I wanted, its continuing the action list from the original button press thats got me stuck.

    Thanks

  5. #5
    Join Date
    Mar 2005
    Location
    Los Angeles, CA
    Posts
    1,003

    Default

    You could try setting a timer from the last code in your flow that you do have executing.

    Cheers,
    Tim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •