Results 1 to 8 of 8

Thread: Linux, QT and qml! You have my attention! ...and I have a transport tcp problem

Threaded View

  1. #1

    Post Linux, QT and qml! You have my attention! ...and I have a transport tcp problem

    I have long been looking for a home automation package that would run on a Linux server. I even played with the idea of learning QT so that I could write my own software for this. Now that I have found your Girder 6 software and read the manual I realize that this is what I need!

    Will you be preparing packages for Debian wheezy (64 bit)?

    Will there be a Netremote app for Blackberry 10, Ubuntu phone and sailfish (Jolla) as these are all QT and qml platforms (not sure what phone I’ll be getting next)?

    I hope the whole home pro (WHP) licenses will allow cross platform usage (eg. Windows and Linux).

    And now to the problem I have.

    I am interested in writing a Lua-driver (RS-232 and raw tcp/ip) for my Sharp tv (LC-46LE831S) and I have been doing some test but I can't get Girder to send a text string using your "simpleSendAndReceive.lua" example (C:\Program Files\Promixis\Girder 6\lua\examples).

    I have copied "simpleSendAndReceive.lua" to C:\Program Files\Promixis\Girder 6\lua\sharp

    I have a scripting action triggered by Girders event "GirderStarted" (I also tried LuaStarted). This script runs without any errors and my debug message is printed (I can also see that address and port '127.0.0.1', 1002 shows up in Girders variable inspector).
    --
    SimpleSendAndReceive = require('sharp.simpleSendAndReceive')
    simpleSendAndReceive = SimpleSendAndReceive.new('127.0.0.1', 1002)
    print("scripting action triggered by GirderStarted event") -- debug
    --

    Next I trigger a Girder scripting action (from a key down event) to send a string but this doesn’t work. Although my debug message is printed to the Lua Console .
    --
    simpleSendAndReceive:send("POWR 1\r")
    print("Power on") -- debug
    --

    I have open my firewall for Girder 6 and even tried to turn it off but I can’t seem to get a message go through, what could I be doing wrong?

    If I create a Lua script (and place it in a Girder scripting action triggered by a key down event) I can connect to a server (I use Hercules setup utility from hw-group as a test tool) on 127.0.0.1 (localhost) port 1002 and send string "POWR 1\r”.
    --
    local host, port = "127.0.0.1", 1002
    local socket = require("socket")
    local tcp = assert(socket.tcp())
    tcp:connect(host, port);
    print("Conected") -- debug
    tcp:send("POWR 1\r")
    tcp:close()
    --

    I also tried entering my Yahoo SMTP setting in Girder (my yahoo SMTP settings works from within mozilla Thunderbird on Ubuntu 14.04 same hardware, network etc.) but I get "Could not connect to host" error. What could be the reson for this?

    Any pointers would be appreciated!


    Joachim

    I am Running Windows 8.1 64 bit and Girder 6.0.0.55 x64
    Attached Files Attached Files
    Last edited by Yoggi; April 20th, 2014 at 05:21 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •