Results 1 to 5 of 5

Thread: Sunrise scheduler has stopped working a few days ago

  1. #1
    Join Date
    Jun 2012
    Location
    Wabash, IN
    Posts
    102

    Default Sunrise scheduler has stopped working a few days ago

    Hi Ron....or anyone else out there that can help,
    I've been using the scheduler to automate some outdoor lighting for over a year now and it's been working flawlessly until the last 3 or 4 days. For some reason the sunset scheduler still turns them on but the sunrise one never turns them back off. I've restarted the computer and that didn't help. I do not see any errors in the logger. I can still manually turn them off with Girder. It's as if the scheduler no longer knows when it's sunrise. I've attached 2 screenshots of the scheduler.


    Thanks for any help you an provide,
    Casey

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Girder Screenshot 8-30-2015.jpg 
Views:	131 
Size:	107.3 KB 
ID:	6905   Click image for larger version. 

Name:	Girder Screenshot 2 8-30-2015.jpg 
Views:	135 
Size:	120.0 KB 
ID:	6904  

  2. #2
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Strange. I tried your coordinates and offset here and it works. Can you send me your C:\Users\<YOURNAMEHERE>\AppData\Local\Promixis\Gir der 6\plugin_235.cfg file?
    Ron
    No support through PM

  3. #3
    Join Date
    Jun 2012
    Location
    Wabash, IN
    Posts
    102

    Default

    Here's the cfg file Ron...


    [
    {
    "device": 235,
    "eventString": "Sunset+20",
    "running": true,
    "tasks": [
    {
    "begin": 0,
    "end": 0,
    "every": 1,
    "id": 3,
    "lat": 40.800800000000002,
    "lng": -85.827200000000005,
    "next": 1441671870,
    "offset": 20,
    "previous": 1441585620,
    "randDist": 0,
    "randMax": 0,
    "randMin": 0,
    "timezone": "America/New_York",
    "type": 2
    }
    ],
    "uuid": "{8a63d2b2-3dd5-4db5-99fd-c73c196c1152}"
    },
    {
    "device": 235,
    "eventString": "Sunrise-20",
    "running": true,
    "tasks": [
    {
    "begin": 0,
    "end": 0,
    "every": 1,
    "id": 3,
    "lat": 40.800800000000002,
    "lng": -85.827200000000005,
    "next": 0,
    "offset": -20,
    "previous": 1440672360,
    "randDist": 0,
    "randMax": 0,
    "randMin": 0,
    "timezone": "America/New_York",
    "type": 3
    }
    ],
    "uuid": "{7ad292f4-7377-4668-ae01-4f73a18e8471}"
    },
    {
    "device": 235,
    "eventString": "1050PM",
    "running": true,
    "tasks": [
    {
    "begin": 0,
    "end": 0,
    "every": 1,
    "hour": 22,
    "id": 3,
    "minute": 50,
    "next": 1441680600,
    "previous": 1441594200,
    "randDist": 0,
    "randMax": 0,
    "randMin": 0,
    "type": 5
    }
    ],
    "uuid": "{d2c47b64-3bf6-437c-9ca2-00367d5a5200}"
    },
    {
    "device": 235,
    "eventString": "1049PM",
    "running": true,
    "tasks": [
    {
    "begin": 0,
    "end": 0,
    "every": 1,
    "hour": 22,
    "id": 3,
    "minute": 49,
    "next": 1441680540,
    "previous": 1441594140,
    "randDist": 0,
    "randMax": 0,
    "randMin": 0,
    "type": 5
    }
    ],
    "uuid": "{dec6cb58-fe82-4506-9884-354c75912150}"
    },
    {
    "device": 235,
    "eventString": "Sunrise",
    "running": true,
    "tasks": [
    {
    "begin": 0,
    "end": 0,
    "every": 1,
    "id": 3,
    "lat": 40.800800000000002,
    "lng": -85.827200000000005,
    "next": 0,
    "offset": 0,
    "previous": 1440673560,
    "randDist": 0,
    "randMax": 0,
    "randMin": 0,
    "timezone": "America/New_York",
    "type": 3
    }
    ],
    "uuid": "{e004a2ab-e120-4162-9d61-cf6616168211}"
    }
    ]

  4. #4
    Join Date
    Jun 2012
    Location
    Wabash, IN
    Posts
    102

    Default

    Ron, I went ahead and deleted the existing tasks and recreated them and they look as though they may work because it's showing a "next" time which the others were not. This has worked fine for over a year so I don't know why it changed but I would think it about has to be a bug somewhere. I'll keep you posted.

    Thanks,
    Casey

    Update: This worked. The lights shut off at the appropriate time today. I still don't have any idea why it quit working and this fixed it but hopefully it doesn't happen again.
    Last edited by caseyp; September 8th, 2015 at 09:57 AM.

  5. #5
    Join Date
    Jan 1998
    Location
    Jupiter, FL
    Posts
    13,553

    Default

    Thanks for reporting this one. I have found the bug and will release an update this week. There was a rounding error which was causing your coordinates at August 28, 2015 to create an invalid date for the sunrise.
    Ron
    No support through PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •