Results 1 to 6 of 6

Thread: Girder License Path "/etc/xdg/Promixis/"

Threaded View

  1. #1
    Join Date
    Jan 2017
    Posts
    6

    Unhappy Girder License Path "/etc/xdg/Promixis/"

    Tried to help myself but 8+ hours in asking for help!

    I set up Girder 6 on Raspberry Pi about a week ago and it was working great. (Service / back-end on RPi).

    My Girder trial license just expired and so I went to put the paid license info in, replacing the trial info that was in
    Code:
    /opt/girder/qt/etc/xdg/Promixis/pluginLicenses.conf
    I then saved the file and rebooted but the G6 Service did not load at boot of the RPi.

    I then navigated to
    Code:
    /opt/girder
    and tried
    Code:
    sudo ./Girder6Service
    and got the following:

    Code:
    pi@raspberrypi:~ $ cd /opt/girder/
    pi@raspberrypi:/opt/girder $ sudo ./Girder6Service
    Girder License Path  "/etc/xdg/Promixis/"

    Notice that the license path
    Code:
    /etc/xdg/Promixis/
    is not the same as where the license info had been before:
    Code:
    /opt/girder/qt/etc/xdg/Promixis/pluginLicenses.conf
    (It was automatically located there when I had initially run the front-end with the trial version since it prompted me for the license. I can still get it to prompt me for a license on the front-end (if I manually remove the license file to test whether it prompts me) but the license doesn't seem to be able to be found when I run the back-end.

    When I run
    Code:
    sudo ./Girder6
    the front-end opens on the RPi (when in GUI mode) and the other devices I have (Windows 10, Android NetRemote) then see the back-end on the RPi and all is well. As soon as I close the front-end, the connection is lost, which makes sense.

    Please can someone help me get back on track here?

    I have also tried removing the license files and uninstalling and reinstalling Girder on the RPi but that has not solved the issue. Lots of reboots in between.

    I also tried to use the info in this forum post but still no go. (Can't post links yet -- noob -- but thread 22141)

    Here's the permissions on the file:
    Code:
    pi@raspberrypi:/opt/girder/qt/etc/xdg/Promixis $ ls -l
    total 4
    -rw-r--r-- 1 root root 127 Feb 28 19:10 pluginLicenses.conf
    I'm happy to start fresh given that troubleshooting this may be worse.

    Mil gracias.
    Last edited by 25TCP; March 1st, 2017 at 10:45 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •