Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Girder does NOT detect the key that is pressed

  1. #1
    Join Date
    Jun 2004
    Posts
    7

    Default Girder does NOT detect the key that is pressed

    I have KWorld KWorld TV878RF.
    I am using Girder 3.3.1c with the plugin for KWorld

    When I press a key on the remote girder does NOT detect it.
    Girder detects that a key was pressed on the remote only if I hold the key pressed for some time or if I press the key several times. After Girder detects that a key was pressed then if I press anything on the remote within 1 second then Girder detects the key immediately. If I wait more that 1 second then the next time I press a key I have to hold it or press it multiple times.

    Can somebody please do something about this problem?

  2. #2
    Join Date
    Dec 2001
    Posts
    11,560

    Default

    I don't have your hardware but I am not sure the KWorld plugin works with your version of the KWorld card. Can you check the plugin readme and make sure it matches your card.

  3. #3
    Join Date
    Jun 2004
    Posts
    7

    Default

    YES KWorld plugin works with my card.

    1)Girder detects that the key is pressed but ONLY if I hold it for some
    time or if I press it mutiple times.


    After the first detected keypress, If I continue to press keys on the remote everything is fine (detects every key immediately).
    If I dont press anything for about 1-2 secounds then I have to repeat the step 1)

    Thank you for your response

  4. #4
    Join Date
    Jun 2004
    Posts
    7

    Default

    MAYBE the plugin should be changed slightly !!
    What information do you need about my card so that you know what is wrong?

  5. #5
    Join Date
    Dec 2001
    Posts
    11,560

    Default

    Strange,

    Try and contact the kworld plugin author and see if he has any ideas.

    Do you know anyone else with your card to test against? Unlikely but worthwhile is to change your remote batteries...

  6. #6
    Join Date
    Jun 2004
    Posts
    7

    Default

    I have tried diferent macine and OS with my card but the result is the same.

    Could someone give me a link to the original drivers for KWorld KW-TV878FBK ?

    I would like to try with those drivers.

    By the way my card is EXACTLY the same with the so called new V-STREAM version with 878A chip

  7. #7
    Join Date
    Dec 2001
    Posts
    11,560

    Default

    Is there an install problem with the current kworld download?

  8. #8
    Join Date
    Jun 2004
    Posts
    7

    Default

    No, the instalation of the kworld plugin is OK.
    I have tried with the btwincap plugin and the appropriate driver.
    Then girder detects every key imediately, but my computer is not stable with those drivers (frequent crashes ocur).

    When I wrote that my card is the same as the new V-STREAM version I meant that I have compared the cards and the only diference between them are two resistors.
    I wonder why is my card considered as diferent model?
    I think that maybe the FBK model might be the same card with diferent model number !!

  9. #9
    Join Date
    Jun 2004
    Posts
    7

    Default

    If you meant the kworld DRIVER download....
    I think that cards that are not v-stream model are discontinued (no support and no drivers on their site)

  10. #10
    Join Date
    Jun 2004
    Posts
    7

    Default

    I have downloaded the source of the kworld plugin from your site.
    I think I know what is the problem, but I can not compile the plugin.
    Can you do that for me?
    I think that the problem is in the following lines:

    IsPressed = !((data & 0x00004000)>>12);
    data = ((data & 0x00003f00)>>8);
    PressKey = data;
    if (IsPressed)
    { if (data!=0x3F) return true; }

    Also, here are some of the values for my card:

    BT848_INT_MASK: 00000000 (00000000 00000000 00000000 00000000)
    BT848_GPIO_OUT_EN: 00008027 (00000000 00000000 10000000 00100111)
    BT848_GPIO_OUT_EN_HIBYTE: 00000000 (00000000 00000000 00000000 00000000)
    BT848_GPIO_DATA: 003f7ffc (00000000 00111111 01111111 11111100)
    BT848_RISC_STRT_ADD: 00000000 (00000000 00000000 00000000 00000000)
    BT848_GPIO_DMA_CTL: 80fc (10000000 11111100)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •